What about extending haskell (or ghc) with mixfix operators, Agda style?. At first sigth it would permit the creation of custom control structures and perhaps more readable DSLs.<br><br><div class="gmail_quote">2009/6/25 Stephan Friedrichs <span dir="ltr"><<a href="mailto:deduktionstheorem@web.de">deduktionstheorem@web.de</a>></span><br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex;"><div class="im">Henning Thielemann wrote:<br>
> [...]<br>
><br>
> <a href="http://haskell.org/haskellwiki/Case" target="_blank">http://haskell.org/haskellwiki/Case</a><br>
<br>
</div>Maybe we (i. e. someone with a wiki account ;) ) should add Jeremy's<br>
proposal - using let and guards - to the page (under section 2.2,<br>
"syntactic suger")? IMHO this is much clearer than "case () of _".<br>
<div class="im"><br>
foo =<br>
let x | 1 > 1 = "uh-oh"<br>
| otherwise = "all is well"<br>
in x<br>
<br>
</div>Regards,<br>
<font color="#888888">Stephan<br>
</font><div class="im"><br>
--<br>
<br>
Früher hieß es ja: Ich denke, also bin ich.<br>
Heute weiß man: Es geht auch so.<br>
<br>
- Dieter Nuhr<br>
_______________________________________________<br>
</div><div><div></div><div class="h5">Haskell-Cafe mailing list<br>
<a href="mailto:Haskell-Cafe@haskell.org">Haskell-Cafe@haskell.org</a><br>
<a href="http://www.haskell.org/mailman/listinfo/haskell-cafe" target="_blank">http://www.haskell.org/mailman/listinfo/haskell-cafe</a><br>
</div></div></blockquote></div><br>